Projects onedev server Issues #957
#957  Can't push to repo with LFS
Closed
Jonathan Wren opened 1 month ago

Hi! Thank you for this software. It was very easy to setup, and has everything I've been looking for.

There's just one problem I've run into: I can't push to projects when the repo has a file stored using LFS. It fails locally with error: failed to push some refs to ssh://server/..., and I get the below error in the server logs (even though I can push and pull for other non-LFS repos, and push/pull the same repo as long as there are no LFS files).

2022-10-18 09:30:02,403 ERROR [pool-2-thread-59] i.o.s.git.LfsAuthenticateCommand Error executing git-lfs-authenticate
io.onedev.commons.utils.ExplicitException: Project not found: /bolivia-survey-cover-image
	at io.onedev.server.git.LfsAuthenticateCommand$1.run(LfsAuthenticateCommand.java:105)
	at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at io.onedev.server.security.SecurityUtils$1.run(SecurityUtils.java:364)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:829)

Can you help?

Robin Shen commented 1 month ago

Can you please show me result of git remote -v in your working directory? Also please paste output of git version and git lfs version

Jonathan Wren commented 1 month ago

For git remote -v, I've tried it a few different ways, and they all have the same result so far. Here's the latest (wren-git is defined in my ssh config):

$ git remote -v
origin  ssh://wren-git/bolivia-survey-cover-image (fetch)
origin  ssh://wren-git/bolivia-survey-cover-image (push)

$ git version
git version 2.35.1

$ git lfs version
git-lfs/3.1.2 (GitHub; darwin amd64; go 1.17.6)
Jonathan Wren commented 1 month ago

And I just upgraded git and git-lfs, but still am seeing the same problem.

$ git version
git version 2.38.1

$ git lfs version
git-lfs/3.2.0 (GitHub; darwin amd64; go 1.18.2)
Robin Shen commented 1 month ago

Please upgrade to build #3079 (7.7.6) to see if it fixes the issue.

Jonathan Wren commented 1 month ago

Yup, that fixed it. Thank you for such a quick response!

Robin Shen changed state to 'Closed' 1 month ago
Previous Value Current Value
Open
Closed
issue 1 of 1
Type
Bug
Priority
Normal
Assignee
Seen Builds
Issue Votes (0)
Watchers (3)
Reference
issue onedev/server#957
Please wait...
Page is in error, reload to recover